Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2017
 
 

net_instance_t(9S)

Name

net_instance_t - packet event structure passed through to hooks

Synopsis

#include <sys/neti.h>

Interface Level

Solaris DDI specific (Solaris DDI).

Description

The net_instance_t data structure defines a collection of instances to be called when relevant events happen within IP. The value returned by the nin_create() function is stored internally and passed back to both the nin_destroy () and nin_shutdown() functions as the second argument. The netid_t passed through to each function can be used to uniquely identify each instance of IP.

Structure Members


    char    *nin_name;
     void    *(*nin_create)(const netid_t);
     void    (*nin_destroy)(const netid_t, void *);
     void    (*nin_shutdown)(const netid_t, void *);

nin_name

Name of the owner of the instance.

nin_create

Function to be called when a new instance of IP is created.

nin_destroy

Function to be called when an instance of IP is being destroyed.

nin_shutdown

Function to be called when an instance of IP is being shutdown. nin_shutdown() is called before nin_destroy() is called.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

netinfo(9F), attributes(5)