mac_group_info - group Information data structure
Solaris architecture specific (Solaris DDI)
The mac_group_info structure is used by a network device driver to describe its ring groups and the groups capabilities. The structure is used as the argument to the mr_gget(9E) driver entry point when querying the group and its capabilities.
mac_group_driver_t mgi_driver; mac_group_start_t mgi_start; mac_group_stop_t mgi_stop; uint_t mgi_count; mac_group_flags_t mgi_flags; mac_group_addmac_t mgi_addmac; mac_group_remmac_t mgi_remmac; mac_group_addvlan_t mgi_addvlan; mac_group_remvlan_t mgi_remvlan; mac_group_setmtu_t mgi_setmtu; mac_group_getsriov_info_t mgi_getsriov_info;
Filled by the driver as handle to the driver's group structure.
The driver entry point for starting a driver's ring group.
The driver entry point for stopping a driver ring group.
The number of rings that are members of this ring group.
Set by the driver to indicate various ring group capabilities including whether the group is the default ring group for the interface, whether the group is a pool of non-active rings, whether the group implements tagging/stripping for all VLANs, or implements transparent VLANs.
The driver entry point to program a MAC address into the driver's hardware for this ring group. This entry is only for RX ring groups. For SRIOV-capable devices, the MAC_GROUP_MACADDR_PRIMARY flag will be used to identify which of the MAC addressed for the group is the primary MAC address of the VF.
The driver entry point to remove a previously programmed MAC address.
The driver entry point to add a VLAN filter to the ring group. The MAC_VLAN_FILTER_TAG_ENABLE flag will be set if the group is to provide tagging/stripping offload.
The driver entry point to remove a VLAN filter.
The driver entry point for the MAC layer to set the MTU for the ring group.
The driver entry point to get the SRIOV information associated with this group.
See attributes(5) for descriptions of the following attributes: