Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2017
 
 

mac_ring_info(9S)

Name

mac_ring_info - ring information data structure

Synopsis

#include <sys/mac_provider.h>

Interface Level

Solaris architecture specific (Solaris DDI)

Description

The mac_ring_info structure is used by a network device driver to describe it's RX and TX rings. The structure is used as an argument to the mr_rget driver entry point when querying the ring.

Structure Members

mac_ring_driver_t       mri_driver;
mac_ring_start_t        mri_start;
mac_ring_stop_t         mri_stop;
mac_intr_enable_t       mri_intr_enable;
mac_intr_disable_t      mri_intr_disable;
ddi_intr_handle_t       mri_intr_ddi_handle;
mac_ring_send_t         mri_tx;
mac_ring_poll_t         mri_poll;
mac_ring_stat_t         mri_stat;
uint_t                  mri_flags;
mri_driver

Filled by the driver as handle to the driver's ring structure.

mri_start

The driver entry point for starting a driver's ring.

mri_stop

The driver entry point for stopping a driver ring.

mri_stat

The driver entry point for getting statistics for ring.

mrii_tx

The driver entry point for transmitting packet for TX rings.

mri_poll

The driver entry point for polling RX ring for packets.

mri_flags

A set of flags for describing ring behavior.

mri_intr_ddi_handle

The DDI interrupt handle associated with the interrupt for this ring.

mri_intr_enable

For RX rings, this driver entry point will enable interrupts again and transition the driver polling to interrupt mode.

mri_intr_disable

For RX rings, this driver entry point will disable interrupts and place the driver into polling mode.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/header
Interface Stability
Committed

See Also

attributes(5), mac_capab_rings(9E), mac_ring_info(9E), mac_group_info(9E), ddi_intr_alloc(9F), mac_register(9S)