Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2017
 
 

iocblk(9S)

Name

iocblk - STREAMS data structure for the M_IOCTL message type

Synopsis

#include <sys/stream.h> 

Interface Level

Architecture independent level 1 (DDI/DKI).

Description

The iocblk data structure is used for passing M_IOCTL messages.

Structure Members

int         ioc_cmd;      /* ioctl command type */
cred_t      *ioc_cr;      /* full credentials */
uint_t      ioc_id;       /* ioctl id */
uint_t      ioc_flag;     /* ioctl flags */
uint_t      ioc_count;    /* count of bytes in data field */
int         ioc_rval;     /* return value */
int         ioc_error;    /* error code */

See Also

STREAMS Programming Guide