Table Tab

The Table tab is where you can explore your dataset query results without altering the source data of any associated workbook visualizations and without having to set a layout. Any fields that are included in the underlying dataset appear in the Dataset Panel on the left. To build your table, drag fields from the Dataset Panel to the Viewer.

You can create multiple table views in a single workbook using the dataset query results.

For information about how to explore your data in a table view, see Workbook Table Views.

The elements of the Table View tab are identified in the image below:

Table view

1

Workbook Information — Click to view or edit the workbook name, description, internal ID, or to add a translatable portlet name to your Analytics portlet. This information is available from anywhere within the workbook.

For more information about translatable Analytics portlet names, see Adding Translatable Analytics Portlet Names.

2

Undo, Redo, and Refresh — Undo or redo your latest edits, and refresh the data in the workbook visualization you are currently in. The undo and redo options apply to any action within the workbook and not just the current tab you are in. For more information about data refreshing, see Data Refresh in SuiteAnalytics Workbook.

3

Add — Click the add icon to add a new workbook visualization.

4

Dataset Panel — The leftmost area of any workbook visualization, the Dataset Panel contains all of the fields included in the selected dataset. To build a workbook visualization, drag fields from the Dataset Panel to the Layout Panel or the Table Viewer. You can also access and edit the underlying dataset, or switch to a different dataset using the Dataset Selector at the top of the panel.

  • To view or edit a dataset, click the dataset name in the Dataset Selector.

  • To view additional information about a field, point to the field and click the Information icon icon.

  • To collapse the Dataset Panel and expand the Viewer, click the double arrows Collapse arrows icon.

5

Dataset Selector — This list enables you to access and edit the selected dataset, select a different dataset, or connect a dataset that is not already used in another workbook visualization.

  • To view or edit a dataset, click the dataset name in the Dataset Selector. Alternatively, click the menu icon and select Open Dataset.

  • To connect or create a new dataset, click the arrow and select Connect Dataset.

  • To save or discard changes to the selected dataset, click the menu icon and select Save Changes or Discard Changes. You must save or discard changes to any datasets connected to the workbook before you can save the workbook.

6

Export — Click this icon to export a CSV file of the table.

7

Table Viewer — The Table Viewer displays your table automatically after you add fields to it. In the Table Viewer itself, you can customize the appearance of the columns, and sort and filter your data.

  • To customize the appearance of the your table, you can perform the following actions:

    • To rename a field, click the Field Menu icon Field menu icon and select Rename....

      Note:

      The change applies only to the column name of the selected table view .

    • To change the order of the columns, drag them to the desired position or click the Field Menu icon Field menu icon and select one of the move options.

    • To remove unwanted columns, click the Field Menu icon Field menu icon in the column header that you want to remove, and then select Remove Column.

  • To filter and sort your data, click the Field Menu icon Field menu icon next to the field you want and then perform the following actions as needed:

    • To apply the default sorting options to the table, select Ascending or Descending.

    • To apply advanced sorting options, select Add Sort.... For more information, see Advanced Sorting Options.

    • To filter your data, select Filter... and then define the filtering conditions. For more information, see Value-based Filters.

  • To apply conditional formatting to your data, click the Field Menu icon Field menu icon in the column header of the field you want to highlight, then point to Conditional Formatting and select Manage Conditional Formatting. For more information, see Conditional Formatting

8

Navigation Panel — Displays the number of rows shown in your table view and lets you navigate through different pages.

To view different pages, click the arrows at the bottom of the viewer.

9

The displayed data refresh details are different depending on whether the Cached Data in Datasets feature is enabled or not:

  • Cached Response / Real-time Response Data from [time] — Displayed when the Cached Data in Datasets feature is enabled. Displays if the workbook visualization is showing real-time data or cached data, and the time when the data was updated.

  • Last Updated — Displayed when the Cached Data in Datasets feature is disabled. Displays the time when the data in the current workbook visualization was last updated. To retrieve the latest results, click the Refresh icon.

For more information, see Data Refresh in SuiteAnalytics Workbook.

10

Workbook Menu — This menu is available from within all workbook visualizations.

  • Click Share to share the workbook and any connected datasets with other users in your account.

    For more information, see Accessing and Sharing Workbooks and Datasets

  • Click Save to save your workbook, including all selections made in each visualization. You can only save your workbook if the connected datasets have also been saved. If you do not own the connected datasets, save copies using different names.

11

Learn about Analytics — Click Learn about Analytics to open a panel that lists all SuiteAnaltyics Workbook videos as well as a description. To view a video, click the thumbnail and it will open in a new window.

Related Topics

Navigating SuiteAnalytics Workbook
Analytics Home Page
Dataset Builder
Pivot Tab
Chart Tab

General Notices