|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- parse the Card Initialization Date tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_DATE(client_handle_t ch, tuple_t *tu, cistpl_date_t *cd);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_date_t structure which contains the parsed CISTPL_DATE tuple information upon return from this function.
This function parses the Card Initialization Date tuple, CISTPL_DATE, into a form usable by PC Card drivers.
The CISTPL_DATE tuple is an optional tuple. It indicates the date and time at which the card was formatted. Only one CISTPL_DATE tuple is allowed per PC Card.
The structure members of cistpl_date_t are:
uint32_t time; uint32_t day
The fields are defined as follows:
This field indicates the time at which the PC Card was initialized.
This field indicates the date the PC Card was initialized.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA