|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- return normalized driver name
#include <sys/ddi.h> #include <sys/sunddi.h> const char *ddi_driver_name(dev_info_t *devi);
Solaris DDI specific (Solaris DDI).
A pointer to the device's dev_info structure.
ddi_driver_name() returns the normalized driver name. This name is typically derived from the device name property or the device compatible property. If this name is a driver alias, the corresponding driver name is returned.
ddi_driver_name() returns the actual name of the driver bound to a device.
ddi_driver_name() can be called from kernel, or interrupt context.
The name returned by ddi_driver_name() is read-only.