|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- enable, disable put and service routines
#include <sys/stream.h> #include <sys/ddi.h> void qprocson(queue_t *q);
void qprocsoff(queue_t *q);
Architecture independent level 1 (DDI/DKI).
Pointer to the RD side of a STREAMS queue pair.
The qprocson() enables the put and service routines of the driver or module whose read queue is pointed to by q. Threads cannot enter the module instance through the put and service routines while they are disabled.
The qprocson() function must be called by the open routine of a driver or module before returning, and after any initialization necessary for the proper functioning of the put and service routines.
The qprocsoff() function must be called by the close routine of a driver or module before returning, and before deallocating any resources necessary for the proper functioning of the put and service routines. It also removes the queue's service routines from the service queue, and blocks until any pending service processing completes.
The module or driver instance is guaranteed to be single-threaded before qprocson() is called and after qprocsoff() is called, except for threads executing asynchronous events such as interrupt handlers and callbacks, which must be handled separately.
These routines can be called from user, interrupt, or kernel context.
The caller may not have the STREAM frozen during either of these calls.