|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- set or clear the client's client event mask
#include <sys/pccard.h> int32_t csx_RequestSocketMask(client_handle_t ch, request_socket_mask_t *sm);
int32_t csx_ReleaseSocketMask(client_handle_t ch, release_socket_mask_t *rm);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a request_socket_mask_t structure.
Pointer to a release_socket_mask_t structure.
The function csx_RequestSocketMask() sets the client's client event mask and enables the client to start receiving events at its event callback handler. Once this function returns successfully, the client can start receiving events at its event callback handler. Any pending events generated from the call to csx_RegisterClient(9F) will be delivered to the client after this call as well. This allows the client to set up the event handler mutexes before the event handler gets called.
The function csx_ReleaseSocketMask() clears the client's client event mask.
The structure members of request_socket_mask_t are:
uint32_t Socket; /* socket number */ uint32_t EventMask; /* event mask to set or return */
The structure members of release_socket_mask_t are:
uint32_t Socket; /* socket number */
The fields are defined as follows:
Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number.
This field is bit-mapped. Card Services performs event notification based on this field. See csx_event_handler(9E) for valid event definitions and for additional information about handling events.
Client handle is invalid.
csx_ReleaseSocketMask() has not been done.
csx_RequestSocketMask() has not been done.
No PCMCIA hardware installed.
These functions may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA