|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- allocate space from a resource map, wait if necessary
#include <sys/map.h> #include <sys/ddi.h> unsigned long rmalloc_wait(struct map *mp, size_t size);
Architecture independent level 1 (DDI/DKI).
Pointer to the resource map from which space is to be allocated.
Number of units of space to allocate.
The rmalloc_wait() function requests an allocation of space from a resource map. rmalloc_wait() is similar to the rmalloc(9F) function with the exception that it will wait for space to become available if necessary.
The rmalloc_wait() function returns the base of the allocated space.
This function can be called from user, interrupt, or kernel context. However, in most cases rmalloc_wait() should not be called from interrupt context.