|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- tell if a device is installed in a slave access only location
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_slaveonly(dev_info_t *dip);
Solaris DDI specific (Solaris DDI).
A pointer to the device's dev_info structure.
The ddi_slaveonly() function tells the caller if the bus, or part of the bus that the device is installed on, does not permit the device to become a DMA master, that is, whether the device has been installed in a slave access only slot.
The device has been installed in a slave access only location.
The device has not been installed in a slave access only location.
The ddi_slaveonly() function can be called from user, interrupt, or kernel context.