|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- asynchronous STREAMS perimeter upgrade
#include <sys/stream.h> #include <sys/ddi.h> void qwriter(queue_t *qp, mblk_t *mp, void (*func)(), int perimeter);
Solaris DDI specific (Solaris DDI).
Pointer to the queue.
Pointer to a message that will be passed in to the callback function.
A function that will be called when exclusive (writer) access has been acquired at the specified perimeter.
Either PERIM_INNER or PERIM_OUTER.
qwriter() is used to upgrade the access at either the inner or the outer perimeter from shared to exclusive and call the specified callback function when the upgrade has succeeded. See mt-streams(9F). The callback function is called as:
(*func)(queue_t *qp, mblk_t *mp);
qwriter() will acquire exclusive access immediately if possible, in which case the specified callback function will be executed before qwriter() returns. If this is not possible, qwriter() will defer the upgrade until later and return before the callback function has been executed. Modules should not assume that the callback function has been executed when qwriter() returns. One way to avoid dependencies on the execution of the callback function is to immediately return after calling qwriter() and let the callback function finish the processing of the message.
When qwriter() defers calling the callback function, the STREAMS framework will prevent other messages from entering the inner perimeter associated with the queue until the upgrade has completed and the callback function has finished executing.