|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- cancel previous qtimeout function call
#include <sys/stream.h> #include <sys/ddi.h> clock_t quntimeout(queue_t *q, timeout_id_t id);
Solaris DDI specific (Solaris DDI).
Pointer to a STREAMS queue structure.
Opaque timeout ID a previous qtimeout(9F) call.
The quntimeout() function cancels a pending qtimeout(9F) request. The quntimeout() function is tailored to be used with the enhanced STREAMS framework interface, which is based on the concept of perimeters. (See mt-streams(9F).) quntimeout() returns when the timeout has been cancelled or finished executing. The timeout will be cancelled even if it is blocked at the perimeters associated with the queue. quntimeout() should be executed for all outstanding timeouts before a driver or module close returns. All outstanding timeouts and bufcalls must be cancelled before a driver close routine can block and before the close routine calls qprocsoff(9F).
The quntimeout() function returns -1 if the id is not found. Otherwise, quntimeout() returns a 0 or positive value.
The quntimeout() function can be called from user, interrupt, or kernel context.