|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- Auto Service Request registration utility
asradm send [-n] [activate|audit|deactivate|fault|heartbeat|test]
asradm register -u username [-p password-file] [-e endpoint_URL]
asradm set-proxy [-i] | [-h host[:port]] [-u username] [-p password-file]
The asradm utility is used by a privileged system administrator to register hosts for enrollment in the Oracle Auto Service Request (ASR) for Oracle Sun systems. Using auto-case generation improves system availability and expedites the diagnostic process when specific hardware faults occur.
Once the system has been registered with a valid My Oracle Support (MOS) account the smf(5) service, asr-notify, will start to send HTTPS/XML telemetry either directly to the configured endpoint or through an optional HTTP proxy.
The asradm utility can also list the current registration state as seen from the registered server. This only confirms that messages are being sent to the Oracle ASR service and does not mean the system is actively being monitored. The user must log into their MOS account and activate the service for the system. An email should be sent to the user after registration that will describe the specific details needed to complete enrollment.
ASR messages can be sent manually using the send subcommand. The content of ASR messages can also be viewed without actually sending the messages as well. The generation of messages can be done even if the system has not been registered.
The system can also be unregistered from the ASR service, which will remove the system from being monitored and will disable all telemetry sent by the system.
The following options are supported:
Sets the endpoint URL used for registration and all message telemetry. The default value is transport.sun.com sends all telemetry directly to Oracle service. A different URL can be used to support a local instance of an ASR Manager solution. The local ASR Manager can be used to aggregate telemetry from many hosts instances.
Sets the HTTPS proxy host and optional port number to use for connecting to the internet. If a port is not specified, the default port value of 80 is used.
Sets the HTTPS connection to be a direct internet connection and thus not use any proxy host. This option will clear any previously set HTTPS proxy information.
Do a dry run of sending an event, which displays the message data to stdout that would have been sent.
When used with the register subcommand, this specifies the MOS user name to be associated with registrations of products on this system. When used with the set-proxy subcommand this specifies the HTTPS proxy user name used for message transport.
This should be a single-line file containing a password value. It can be immediately removed after running this command. When used with the register subcommand, this specifies the password associated with the MOS user name. When used with the set-proxy subcommand, this option specifies the password associated with the HTTPS proxy used to connect to the internet. If the -p option is not entered and the -u option was set, the user will be prompted for the password.
The asradm subcommands are described as follows.
Registers the system with MOS using the supplied authentication credentials. The MOS password will be used only for initial registration, to obtain a token used for all future telemetry and will not be stored anywhere on the system.
If the host system is behind a firewall, then the HTTP proxy settings must be set using the set-proxy command before registering the system.
Once registered, an ASR activation message will be sent that will request support for automated support call generation. Subsequently, an email will be sent to the registered user giving the status of the service request.
Shows the current authenticated MOS user name and the network connectivity information needed for HTTPS communication with MOS. If no registration has yet been done (by means of the register command), then the status of Unregistered is displayed.
Sets up the HTTPS connection information to be used for sending all ASR messages. Either a direct connection can be made or an HTTPS proxy can be defined.
Sends an ASR deactivation event and removes all configured registration information. No further telemetry will be sent and the Oracle ASR service will no longer generate any automated support calls.
Manually sends a specified ASR message to the Oracle ASR service or, with the dry run option (-n), display ASR messages.
Example 1 Setup Internet Connection to Use an HTTPS Proxy
The following command will route all messages through an HTTPS proxy host webproxy.example.com on port 8080.
# asradm set-proxy -h webproxy.example.com:8080
Example 2 Registering an MOS ID
The following command is used to interactively authenticate and register this system with the given MOS ID for use with ASR. Following this, you will be prompted for your support user name and password.
# asradm register
Example 3 Authenticating Non-interactively
This is similar to set—proxy example, above. The difference is that the MOS user name and password are specified by means of the command line.
# asradm register -u email@example.com -p mypassword
Example 4 Viewing Contents of Audit Message
The command below will display an audit message without sending the event. This will work even if the ASR service has not been registered.
# asradm send -n audit
See attributes(5) for descriptions of the following attributes: