|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- report information about a device entry in a device maps file
dminfo [-v] [-a] [-f pathname]
dminfo [-v] [-a] [-f pathname] -n dev -name...
dminfo [-v] [-a] [-f pathname] -d dev -path...
dminfo [-v] [-a] [-f pathname] -t dev -type...
dminfo [-v] [-f pathname] -u dm -entry
dminfo reports and updates information about the device_maps(4) file.
The following options are supported
Succeed if any of the requested entries are found. If used with -v, all entries that match the requested case(s) are printed.
Search by dev-path. Search device_maps(4) for a device special pathname in the device_list field matching the dev-path argument. This option cannot be used with -n, -t or -u.
Use a device_maps file with pathname instead of /etc/security/device_maps.
Search by dev-name. Search device_maps(4) for a device_name field matching dev-name. This option cannot be used with -d, -t or -u.
Search by dev-type. Search device_maps(4) for a device_type field matching the given dev-type. This option cannot be used with -d, -n or -u.
Update the device_maps(4) file. This option is provided to add entries to the device_maps(4) file. The dm-entry must be a complete device_maps(4) file entry. The dm-entry has fields, as in the device_maps file. It uses the colon (:) as a field separator, and white space as the device_list subfield separators. The dm-entry is not made if any fields are missing, or if the dm-entry would be a duplicate. The default device maps file can be updated only by the super user.
Verbose. Print the requested entry or entries, one line per entry, on the standard output. If no entries are specified, all are printed.
See attributes(5) for descriptions of the following attributes: