|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- saves and restores information for NAT and state tables
ipfs [-nv] -l
ipfs [-nv] -u
ipfs [-nv] [-d dirname] -R
ipfs [-nv] [-d dirname] -W
ipfs [-nNSv] [-f filename] -r
ipfs [-nNSv] [-f filename] -w
ipfs [-nNSv] -f filename -i <if1>,<if2>
The ipfs utility enables the saving of state information across reboots. Specifically, the utility allows state information created for NAT entries and rules using "keep state" to be locked (modification prevented) and then saved to disk. Then, after a reboot, that information is restored. The result of this state-saving is that connections are not interrupted.
The following options are supported:
Change the default directory used with -R and -W options for saving state information.
Do not take any action that would affect information stored in the kernel or on disk.
Provides a verbose description of ipfs activities.
Operate on NAT information.
Operate on filtering state information.
Unlock state tables in the kernel.
Lock state tables in the kernel.
Read information in from the specified file and load it into the kernel. This requires the state tables to have already been locked and does not change the lock once complete.
Write information out to the specified file and from the kernel. This requires the state tables to have already been locked and does not change the lock once complete.
Restores all saved state information, if any, from two files, ipstate.ipf and ipnat.ipf, stored in the /var/db/ipf directory. This directory can be changed with the -d option. The state tables are locked at the beginning of this operation and unlocked once complete.
Saves in-kernel state information, if any, out to two files, ipstate.ipf and ipnat.ipf, stored in the /var/db/ipf directory. This directory can be changed with the -d option. The state tables are locked at the beginning of this operation and unlocked once complete.
See attributes(5) for descriptions of the following attributes:
Arguably, the -W and -R operations should set the locking and, rather than undo it, restore it to what it was previously.
Fragment table information is currently not saved.