|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- list user and system login information
/usr/bin/logins [-admopstux] [-g group...] [-l login_name...]
This command displays information on user and system logins known to the system. Contents of the output is controlled by the command options and can include the following: user or system login, user id number, passwd account field value (user name or other information), primary group name, primary group id, multiple group names, multiple group ids, home directory, login shell, and four password aging parameters. The default information is the following: login id, user id, primary group name, primary group id and the account field value. Output is sorted by user id, system logins, followed by user logins.
Options may be used together. If so, any login that matches any criteria are displayed.
The following options are supported:
Add two password expiration fields to the display. The fields show how many days a password can remain unused before it automatically becomes inactive, and the date that the password expires.
Selects logins with duplicate uids.
Selects all users belonging to group, sorted by login. Multiple groups can be specified as a comma-separated list. When the -l and -g options are combined, a user is only listed once, even if the user belongs to more than one of the selected groups.
Selects the requested login. Multiple logins can be specified as a comma-separated list. Depending on the nameservice lookup types set in /etc/nsswitch.conf, the information can come from the /etc/passwd and /etc/shadow files and other nameservices. When the -l and -g options are combined, a user is only listed once, even if the user belongs to more than one of the selected groups.
Displays multiple group membership information.
Formats output into one line of colon-separated fields.
Selects logins with no passwords.
Selects all system logins.
Sorts output by login instead of by uid.
Selects all user logins.
Prints an extended set of information about each selected user. The extended information includes home directory, login shell and password aging information, each displayed on a separate line. The password information currently consists of password status:
Account has no password
Account is locked for UNIX authentication
Account is a no login account
This account has not yet been activated by the administrator and cannot be used.
Account probably has a valid password
Account password status is unknown. That is, it is not a recognizable hashed password or any of the above entries. See crypt(3C) for valid password hashes.
If the login is passworded, status is followed by the date the password was last changed, the number of days required between changes, and the number of days allowed before a change is required. The password aging information shows the time interval that the user receives a password expiration warning message (when logging on) before the password expires.
See attributes(5) for descriptions of the following attributes: