|Skip Navigation Links
|Exit Print View
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library
- check the label encodings file syntax
/usr/sbin/chk_encodings [-a] [-c maxclass] [pathname]
chk_encodings checks the syntax of the label-encodings file that is specified by pathname. With the -a option, chk_encodings also prints a semantic analysis of the label-encodings file that is specified by pathname. If pathname is not specified, chk_encodings checks and analyzes the /etc/security/tsol/label_encodings file.
If label-encodings file analysis was requested, whatever analysis can be provided is written to the standard output file even if errors were found.
Provide a semantic analysis of the label encodings file.
Accept a maximum classification value of maxclass (default 255) in the label encodings file CLASSIFICATIONS section.
When successful, chk_encodings returns an exit status of 0 (true) and writes to the standard output file a confirmation that no errors were found in pathname. Otherwise, chk_encodings returns an exit status of nonzero (false) and writes an error diagnostic to the standard output file.
The label encodings file contains the classification names, words, constraints, and values for the defined labels of this system.
See attributes(5) for descriptions of the following attributes:
The command output is Not-an-Interface. The command invocation is Committed for systems that implement the DIA MAC policy.
The functionality described on this manual page is available only if the system is configured with Trusted Extensions.
This file is part of the Defense Intelligence Agency (DIA) Mandatory Access Control (MAC) policy. This file might not be applicable to other MAC policies that might be developed for future releases of Solaris Trusted Extensions software.