|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- display cluster information
The clinfo command displays cluster configuration information about the node from which the command is executed.
Without arguments, clinfo returns an exit status of 0 if the node is configured and booted as part of a cluster. Otherwise, clinfo returns an exit status of 1.
The following options are supported:
Displays the highest node number allowed to be configured. This is different from the maximum number of nodes supported in a given cluster. The current highest configured node number can change immediately after the command returns since new nodes can be dynamically added to a running cluster.
For example, clinfo -h might return 64, meaning that the highest number you can use to identify a node is 64. See the Sun Cluster 3.0 System Administration Guide for a description of utilities you can use to determine the number of nodes in a cluster.
Prints the number of the node from which clinfo is executed.
The following exit values are returned:
An error occurred.
This is usually because the node is not configured or booted as part of a cluster.
See attributes(5) for descriptions of the following attributes: