|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- DHCP service lock daemon
/usr/lib/inet/dsvclockd [-d 1 | 2] [-f ] [-v]
The dsvclockd daemon is a lock manager that works in conjunction with the Dynamic Host Configuration Protocol (DHCP) Data Service Library (libdhcpsvc). It provides shared or exclusive access to the dhcp_network(4) and dhcptab(4) tables. This service is used by the SUNWbinfiles and SUNWfiles DHCP data store modules. See dhcp_modules(5).
dsvclockd is started on demand by libdhcpsvc. The dsvclockd daemon should be started manually only if command line options need to be specified.
The following options are supported:
Set debug level. Two levels of debugging are currently available, 1 and 2. Level 2 is more verbose.
Run in the foreground instead of as a daemon process. When this option is used, messages are sent to standard error instead of to syslog(3C).
Provide verbose output.
See attributes(5) for descriptions of the following attributes: