Skip Navigation Links | |
Exit Print View | |
Oracle Solaris Cluster Data Services Reference Manual Oracle Solaris Cluster 4.1 |
scalable_asm_diskgroup_proxy(5)
scalable_asm_instance_proxy(5)
SUNW.scalable_asm_diskgroup_proxy(5)
SUNW.scalable_asm_instance_proxy(5)
- resource type implementation for the SAP replica server component of Oracle Solaris Cluster HA for SAP Web Application Server
The SUNW.saprepl resource type represents the SAP replica server component in an Oracle Solaris Cluster configuration. This resource type is part of a set of resource types for the SAP Web Application Server platform. The other components are the SAP enqueue server (represented by the SUNW.sapenq resource type), the SAP message server (represented by the SUNW.sapscs resource type), and the SAP web application server component (represented by the SUNW.sapwebas resource type).
The SAP enqueue server resource and the SAP message server resource must be in the same failover group (called the SAP central services resource group), because they fail over together. The SAP replica server resource must be in a different failover resource group from the SAP enqueue server resource, because the SAP replica server resource must not fail over with the SAP enqueue server resource.
The resource group affinities must be set to ensure that the SAP central services resource group fails over to the node where the SAP replica resource group has been running and that the SAP replica resource group fails over to another available node.
The resource dependencies must be set to ensure that the SAP replica server resource depends on the SAP enqueue server resource being online.
With the resource group affinities and resource dependencies set as described above, if the SAP enqueue server experiences any hardware or software failure, the SAP central services resource group will fail over to the node where the SAP replica resource group has been running and the SAP replica resource group will fail over to another available node. If the SAP message server experiences any failure, the SAP message server resource will be restarted locally a configurable number of times before a failover is initiated.
Create all these dependencies when you configure the Oracle Solaris Cluster HA for SAP Web Application Server data service.
Standard properties and extension properties that are defined for the SUNW.saprepl resource type are described in the subsections that follow. To set these properties for an instance of the SUNW.saprepl resource type, use the clresourcetype(1CL) command.
Standard resource properties are overridden for this resource type as follows:
2
2
Any time
3600
620
Any time
3600
120
Any time
For a description of these standard resource properties, see r_properties(5).
The extension properties of this resource type are as follows:
The child process monitoring level for the process monitor facility (PMF). This property is equivalent to the -C option of pmfadm.
The default value of -1 indicates that child process monitoring will not be performed. Positive values indicate the desired level of child process monitoring.
Integer
-1
No range defined
Any time
The directory for the startup and monitor log files that are created by the SAP replica server application.
String
The home directory of the administration user, as specified by the extension property SAP_User.
Not applicable
When disabled
The maximum number of restarts by the process monitor facility (PMF) that are allowed for the SAP replica server fault monitor.
Integer
4
No range defined
Any time
The interval in minutes between restarts of the SAP replica server fault monitor.
Integer
2
No range defined
Any time
Currently unused. The timeout value in seconds that the SAP replica server fault monitor uses to probe an SAP replica server instance. The replica server is started by PMF and monitored by PMF. No additional probing is currently performed by the fault monitor.
Integer
30
Minimum = 2; no maximum defined
Any time
The full path to the SAP replica server profile.
String
No default defined
Not applicable
When disabled
The full path to the SAP replica server executable.
String
No default defined
Not applicable
When disabled
The administration user for the SAP replica server.
String, where letters are in lowercase
No default defined
Not applicable
When disabled
The signal that is sent to the application to stop the SAP replica server application.
Integer
2 (equivalent to SIGINT)
1–37
Any time
Example 1 Creating Resources for SUNW.sapenq, SUNW.sapscs, and SUNW.saprepl
For this example to work, you must first install the Oracle Solaris Cluster HA for SAP Web Application Server data service, which includes all the packages to make the SAP Web Application Server components highly available.
The failover SAP central services resource group contains the SAP enqueue server resource, the SAP message server resource, and the logical host resource. The following commands are an example of creating the SAP central services resource group:
# clresourcegroup create central-rg # clreslogicalhostname create -g central-rg -l central-lh \\ -N sc_ipmp0@1,sc_ipmp0@2,sc_ipmp0@3,sc_ipmp0@4 central-lh-rs
To bring online the SAP central services resource group, the following command is run:
# clresourcegroup online -M central-rg
The failover SAP replica resource group contains the SAP replica server resource and a logical host resource. The following commands are an example of creating the SAP replica resource group:
# clresourcegroup create repl-rg # clreslogicalhostname create -g repl-rg -l repl-lh \\ -N sc_ipmp0@1,sc_ipmp0@2,sc_ipmp0@3,sc_ipmp0@4 repl-lh-rs
To bring online the SAP replica server resource group, the following command is run:
# clresourcegroup online -M repl-rg
Setting weak positive resource group affinity between the SAP central services resource group and the SAP replica resource group ensures that, in case of failover, the SAP central services resource group fails over to the node where the SAP replica resource group has been running. The following command is an example of setting this affinity:
# clresourcegroup set -p RG_affinities=+repl-rg central-rg
The two resource groups must be mastered on different nodes before the strong negative affinity can be set. Therefore, either the SAP central services resource group or the SAP replica resource group must be switched to another node. The following command is an example of switching the SAP central services resource group to another node:
# clresourcegroup switch -n Node2 central-rg
Setting strong negative resource group affinity between the SAP replica resource group and the SAP central services resource group ensures that, in case of failover, after the SAP central services resource group fails over to the node where the SAP replica resource group has been running, the SAP replica resource group will fail over to another available node. The following command is an example of setting this affinity:
# clresourcegroup set -p RG_affinities=--central-rg repl-rg
To register the resource types, the following commands are run:
# clresourcetype register SUNW.sapenq # clresourcetype register SUNW.sapscs # clresourcetype register SUNW.saprepl
To create the SAP enqueue server resource in the SAP central services resource group, the following command is run:
# clresource create -g central-rg -t SUNW.sapenq \\ -p Enqueue_Profile=/usr/sap/SC3/SYS/profile/SC3_SCS01_central-lh \\ -p Enqueue_Server=/sapmnt/SC3/exe/enserver \\ -p SAP_User=sc3adm \\ -p Enqueue_Instance_Number=01 sapenq-rs
To create the SAP message server resource in the SAP central services resource group, the following command is run:
# clresource create -g central-rg -t SUNW.sapscs \\ -p SAP_SID=SC3 -p SAP_Instance_Number=01 \\ -p SAP_Instance_Name=SCS01 \\ -p Msg_Server_Port=3601 msg-rs
To create the SAP replica server resource in the SAP replica resource group, the following command is run:
#clresource create -g repl-rg -t SUNW.saprepl \\ -p Replica_Profile=/usr/sap/SC3/SYS/profile/SC3_REP01 \\ -p Replica_Server=/sapmnt/SC3/exe/enrepserver \\ -p SAP_User=sc3adm \\ -p Resource_Dependencies=enq-rs repl-rs
See attributes(5) for descriptions of the following attributes:
|
clresource(1CL), clresourcegroup(1CL)clresourcetype(1CL), attributes(5), r_properties(5), SUNW.sapenq(5), SUNW.sapscs(5), SUNW.sapwebas(5)