|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- format of specifying variable names to SNMP tools
Variable names for SNMP are in the format of Object Identifiers (ASN.1). There are several methods of representation. Each variable name is given in the format of A.B.C.D...., where A, B, C, and D are subidentifiers in one of two forms of notation. Each subidentifier can be encoded as a decimal integer or a symbol as found in the RFC 1066 MIB. The case of the symbols is not significant. If there is no leading period (.) in the variable name, the name will be formed as if having been preceded with iso.org.dod.internet.mgmt.mib. .
A period must be placed before the first variable if the user is to fully specify the name. For example:
1.1.0 system.sysDescr.0 1.sysDescr.0
...all refer to the same variable name. Likewise:
.22.214.171.124.126.96.36.199.0 .iso.org.dod.internet.mgmt.mib.system.sysdescr.0 .188.8.131.52.2.1.1.sysdescr.0
...all refer to the same variable name.
The description of the variables in the MIB is given in the set of MIB files defined by the MIBS environment variable (or the default list defined at compilation time) and the MIB files in the /etc/sma/snmp/mibs directory (or the MIBDIRS environment variable).
See attributes(5) for descriptions of the following attributes:
RFC 1065, RFC 1066, RFC 1067, ISO IS 8824 (ASN.1)