|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- utmpx and wtmpx database entry formats
#include <utmpx.h> /var/adm/utmpx /var/adm/wtmpx
The utmpx and wtmpx files are extended database files that have superseded the obsolete utmp and wtmp database files.
The utmpx database contains user access and accounting information for commands such as who(1), write(1), and login(1). The wtmpx database contains the history of user access and accounting information for the utmpx database.
Applications should not access these databases directly, but should use the functions described on the getutxent(3C) manual page to interact with the utmpx and wtmpx databases to ensure that they are maintained consistently.
user access and adminstration information
history of user access and adminstrative information