|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- device instance number file
/etc/path_to_inst records mappings of physical device names to instance numbers.
The instance number of a device is encoded in its minor number, and is the way that a device driver determines which of the possible devices that it may drive is referred to by a given special file.
In order to keep instance numbers persistent across reboots, the system records them in /etc/path_to_inst.
Note that it is generally not necessary for the system administrator to change this file, as the system will maintain it.
The system administrator can change the assignment of instance numbers by editing this file and doing a reconfiguration reboot. However, any changes made in this file will be lost if add_drv(1M) or devfsadm(1M) is run before the system is rebooted.
Each instance entry is a single line of the form:
"physical name" instance number "driver binding name"
is the absolute physical pathname of a device. This pathname must be enclosed in double quotes.
is a decimal or hexadecimal number.
is the name used to determine the driver for the device. This name may be a driver alias or a driver name. The driver binding name must be enclosed in double quotes.
Example 1 Sample path_to_inst Entries
Here are some sample path_to_inst entries:
"/iommu@f,e0000000" 0 "iommu" "/iommu@f,e0000000/sbus@f,e0001000" 0 "sbus" "/iommu@f,e0000000/sbus@f,e0001000/sbusmem@e,0" 14 "sbusmem" "/iommu@f,e0000000/sbus@f,e0001000/sbusmem@f,0" 15 "sbusmem" "/iommu@f,e0000000/sbus@f,e0001000/ledma@f,400010" 0 "ledma" "/obio/serial@0,100000" 0 "zs" "/SUNW,sx@f,80000000" 0 "SUNW,sx"
Mapping of physical device names to instance numbers.
If the file is removed the system may not be bootable (as it may rely on information found in this file to find the root, usr or swap device). If it does successfully boot, it will regenerate the file, but after rebooting devices may end up having different minor numbers than they did before, and special files created via mknod(1M) may refer to different devices than expected.
For the same reasons, changes should not be made to this file without careful consideration.
This document does not constitute an API. path_to_inst may not exist or may have a different content or interpretation in a future release. The existence of this notice does not imply that any other documentation that lacks this notice constitutes an API.