|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- make a special file
mknod name b major minor
mknod name c major minor
mknod name p
mknod makes a directory entry for a special file.
The following options are supported:
Create a block-type special file.
Create a character-type special file.
Create a FIFO (named pipe).
The following operands are supported:
The major device number.
The minor device number; can be either decimal or octal. The assignment of major device numbers is specific to each system. You must be the super-user to use this form of the command.
A special file to be created.
See largefile(5) for the description of the behavior of mknod when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
See attributes(5) for descriptions of the following attributes:
If mknod(2) is used to create a device, the major and minor device numbers are always interpreted by the kernel running on that machine.
With the advent of physical device naming, it would be preferable to create a symbolic link to the physical name of the device (in the /devices subtree) rather than using mknod.