|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- send ping to NIS+ servers
/usr/lib/nis/nisping [-uf] [-H hostname] [-r | directory]
/usr/lib/nis/nisping -C [-a] [-H hostname] [directory]
In the first Synopsis line, the nisping command sends a ``ping'' to all replicas of an NIS+ directory. Once a replica receives a ping, it will check with the master server for the directory to get updates. Prior to pinging the replicas, this command attempts to determine the last update “seen” by a replica and the last update logged by the master. If these two timestamps are the same, the ping is not sent. The -f (force) option will override this feature.
Under normal circumstances, NIS+ replica servers get the new information from the master NIS+ server within a short time. Therefore, there should not be any need to use nisping.
In the second Synopsis line, the nisping -C command sends a checkpoint request to the servers. If no directory is specified, the home domain, as returned by nisdefaults(1), is checkpointed. If all directories, served by a given server, have to be checkpointed, then use the -a option.
On receiving a checkpoint request, the servers would commit all the updates for the given directory from the table log files to the database files. This command, if sent to the master server, will also send updates to the replicas if they are out of date. This option is needed because the database log files for NIS+ are not automatically checkpointed. nisping should be used at frequent intervals (such as once a day) to checkpoint the NIS+ database log files. This command can be added to the crontab(1) file. If the database log files are not checkpointed, their sizes will continue to grow.
If the server specified by the -H option does not serve the directory, then no ping is sent.
Per-server and per-directory access restrictions may apply; see nisopaccess(1). nisping uses NIS_CPTIME and NIS_PING (resync (ping) of replicas), or NIS_CHECKPOINT (for checkpoint). Since the NIS_PING operation does not return a status, the nisping command is typically unable to indicate success or failure for resyncs.
Checkpoint all directories on the server.
Send a request to checkpoint, rather than a ping, to each server. The servers schedule to commit all the transactions to stable storage.
Only the host hostname is sent the ping, checked for an update time, or checkpointed.
Force a ping, even though the timestamps indicate there is no reason to do so. This option is useful for debugging.
This option can be used to update or get status about the root object from the root servers, especially when new root replicas are added or deleted from the list.
If used without -u option, -r will send a ping request to the servers serving the root domain. When the replicas receive a ping, they will update their root object if needed.
The -r option can be used with all other options except with the -C option; the root object need not be checkpointed.
Display the time of the last update; no servers are sent a ping.
No servers were contacted, or the server specified by the -H switch could not be contacted.
Some, but not all, servers were successfully contacted.
Example 1 Using nisping
This example pings all replicas of the default domain:
Note that this example will not ping the org_dir and groups_dir subdirectories within this domain.
This example pings the server example which is a replica of the org_dir.foo.com. directory:
example% nisping -H example org_dir.foo.com.
This example checkpoints all servers of the org_dir.bar.com. directory.
example% nisping -C org_dir.bar.com.
If this variable is set, and the NIS+ directory name is not fully qualified, each directory specified will be searched until the directory is found.
See attributes(5) for descriptions of the following attributes:
NIS+ might not be supported in future releases of the Solaris operating system. Tools to aid the migration from NIS+ to LDAP are available in the current Solaris release. For more information, visit http://www.sun.com/directory/nisplus/transition.html.