|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- write to all users over a network
/usr/sbin/rwall -n netgroup...
/usr/sbin/rwall -h hostname -n netgroup
rwall reads a message from standard input until EOF. It then sends this message, preceded by the line:
Broadcast Message . . .
to all users logged in on the specified host machines. With the -n option, it sends to the specified network groups.
Send the broadcast message to the specified network groups.
Specify the hostname, the name of the host machine.
See attributes(5) for descriptions of the following attributes:
The timeout is fairly short to allow transmission to a large group of machines (some of which may be down) in a reasonable amount of time. Thus the message may not get through to a heavily loaded machine.