|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- communicate with a network entity using SNMP GETNEXT requests
snmpgetnext [-Cf] [common options] oid [oid]...
The snmpgetnext utility is an SNMP application that uses the SNMP GETNEXT request to query for information on a network entity. You can specify one or more object identifiers (OIDs) as arguments on the command line. Each variable name must be specified in the format specified in snmp_variables(4) . For each variable, the one that is lexicographically "next" in the remote entity's MIB is returned.
For example, the command:
# snmpgetnext -c public zeus interfaces.ifTable.ifEntry.ifType.1
retrieves the variable interfaces.ifTable.ifEntry.ifType.2:
interfaces.ifTable.ifEntry.ifType.2 = softwareLoopback(24)
If the network entity has an error processing the request packet, an error packet is returned and a message displayed. The message indicates the way in which the request was malformed.
The following options are supported:
If -Cf is not specified, some applications (including snmpget(1M) and snmpgetnext) attempt to fix errors returned by the agent that you were talking to and resend the request. The -Cf option suppresses this fix-and-resend feature.
Fix-and-resend is useful if you specified a nonexistent OID in your request and you are using SNMPv1, which requires "all or nothing" types of requests.
In addition to this option, snmpgetnext takes the common options described in the snmpcmd(1M) manual page.
See attributes(5) for descriptions of the following attributes:
A usage syntax error. A usage message is displayed. Also used for timeout errors.
An error occurred while executing the command. An error message is displayed.