|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- set serial line interface operating parameters
/usr/sbin/syncinit device [ [baud_rate] | [keyword=value,]... | [single-word option]]
The syncinit utility allows the user to modify some of the hardware operating modes common to synchronous serial lines. This can be useful in troubleshooting a link, or necessary to the operation of a communications package.
If run without options, syncinit reports the options as presently set on the port. If options are specified, the new settings are reported after they have been made.
Options to syncinit normally take the form of a keyword, followed by an equal sign and a value. The exception is that a baud rate may be specified as a decimal integer by itself. Keywords must begin with the value shown in the options table, but may contain additional letters up to the equal sign. For example, loop= and loopback= are equivalent.
The following options are supported:
There are also several single-word options that set one or more paramaters at a time:
Example 1 Using syncinit
The following command sets the first CPU port to loop internally, using internal clocking and operating at 38400 baud:
example# syncinit zsh0 38400 loop=yes device: /dev/zsh ppa: 0 speed=38400, loopback=yes, echo=no, nrzi=no, txc=baud, rxc=baud
The following command sets the same port's clocking, local loopback and baud rate settings to their default values:
example# syncinit zsh0 stop loop=no device: /dev/zsh ppa: 0 speed=0, loopback=no, echo=no, nrzi=no, txc=txc, rxc=rxc
See attributes(5) for descriptions of the following attributes:
The name device does not end in a decimal number that can be used as a minor device number.
The string arg that accompanied the speed= option could not be interpreted as a decimal integer.
The string arg did not make sense as an option.
Do not use syncinit on an active serial link, unless needed to resolve an error condition. Do not use this command casually or without being aware of the consequences.