|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- NFS user and group id mapping daemon
The nfsmapid daemon maps to and from NFS version 4 owner and owner_group identification attributes and local UID and GID numbers used by both the NFS version 4 client and server.
nfsmapid uses the passwd and group entries in the /etc/nsswitch.conf file to direct how it performs the mappings.
The nfsmapid daemon has no external, customer-accessible interfaces. You can, however, administratively configure nfsmapid in one of the following ways:
Specify the NFSMAPID_DOMAIN parameter in nfs(4)
Specify the _nfsv4idmapdomain DNS resource record.
Please refer to the System Administration Guide: Network Services for further details.
Contains the domain name currently used by NFSv4.
See attributes(5) for descriptions of the following attributes:
The nfsmapid service is managed by the service management facility, smf(5), under the service identifier:
nfsmapid caches a user's UID and GID. If a user subsequently changes a UID or GID, using one of the utilities listed below, the nfsmapid cache becomes stale. At this point, any NFS operation that gets or set attributes will result in the exchange of this stale information. To resolve this situation, restart nfsmapid, as follows:
# svcadm restart svc:/network/nfs/mapid:default
The utilities that allow you to change UID and GID are:
The nfsmapid daemon might not exist in a future release of Solaris.