|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- convert driver packages to Driver Update format
/usr/bin/pkg2du [-f] [-v] [-d dir] [-o iso] [-l label] [-r release] pkg [pkg ...]
The /usr/bin/pkg2du utility takes one or more packages as input and converts them to Driver Update (DU) format. If the -d option is specified, the resulting DU directory tree is placed in the directory dir. If the -o option is specified, a Solaris ISO image of the DU directory tree is written in the file iso. The ISO image can be burned onto CD/DVD using cdrw(1) or cdrecord(1) (not a SunOS man page) and used during Solaris installation.
At least one of the -d and -o options must be specified. If both are specified, then both an ISO image and a directory tree are generated.
The following options are supported:
Directory where the DU directory should be created.
Create a Solaris ISO image of the DU directory.
If dir/DU or iso exists, remove it without asking first.
Label/volume name of the ISO image (if -o option is specified).
Solaris release number to use. It takes the form of the return from uname -r command, for example, 5.10. If unspecified, the release number of the currently running Solaris is used.
Verbose. Multiple -v options increase verbosity.
The following operands are supported:
One or more packages to be converted to DU format.
Example 1 Creating a DU CD/DVD
The following commands create a DU CD or DVD containing packages SUNWfoo and SUNWbar.
# /usr/bin/pkg2du -r 5.10 -o my.iso SUNWfoo SUNWbar # /usr/bin/cdrw -i my.iso
See attributes(5) for descriptions of the following attributes:
mkisofs(8), (/usr/share/man/man8/mkisofs.8), in the SUNWfsman package (not a SunOS man page)