|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- initialize a NIS+ domain
/usr/lib/nis/nissetup [-Y] [domain]
nissetup is a shell script that sets up a NIS+ domain to service clients that wish to store system administration information in a domain named domain. This domain should already exist prior to executing this command. See nismkdir(1) and nisinit(1M).
A NIS+ domain consists of a NIS+ directory and its subdirectories: org_dir and groups_dir. org_dir stores system administration information and groups_dir stores information for group access control.
nissetup creates the subdirectories org_dir and groups_dir in domain. Both subdirectories will be replicated on the same servers as the parent domain. After the subdirectories are created, nissetup creates the default tables that NIS+ serves. These are auto_master, auto_home, bootparams, cred, ethers, group, hosts, mail_aliases, netmasks, networks, passwd, protocols, rpc, services, and timezone. The nissetup script uses the nistbladm(1) command to create these tables. The script can be easily customized to add site specific tables that are created at setup time.
This command is normally executed just once per domain.
While this command creates the default tables, it does not initialize them with data. This is accomplished with the nisaddent(1M) command.
It is easier to use the nisserver(1M) script to create subdirectories and the default tables.
Specify that the domain will be served as both a NIS+ domain as well as an NIS domain using the backward compatibility flag. This will set up the domain to be less secure by making all the system tables readable by unauthenticated clients as well.
See attributes(5) for descriptions of the following attributes:
NIS+ might not be supported in future releases of the Solaris Operating system. Tools to aid the migration from NIS+ to LDAP are available in the current Solaris release. For more information, visit http://www.sun.com/directory/nisplus/transition.html.