|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- change machine information
setuname [-t] [-n node] [-s name]
The setuname utility changes the parameter value for the system name and node name. Each parameter can be changed using setuname and the appropriate option.
Either or both the -s and -n options must be given when invoking setuname.
The system architecture may place requirements on the size of the system and network node name. The command will issue a fatal warning message and an error message if the name entered is incompatible with the system requirements.
The following options are supported:
Changes the node name. node specifies the new network node name and can consist of alphanumeric characters and the special characters dash, underbar, and dollar sign.
Changes the system name. name specifies new system name and can consist of alphanumeric characters and the special characters dash, underbar, and dollar sign.
Temporary change. No attempt will be made to create a permanent change.
See attributes(5) for descriptions of the following attributes:
setuname attempts to change the parameter values in two places: the running kernel and, as necessary per implementation, to cross system reboots. A temporary change changes only the running kernel.