|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- list package dependencies
pkgdep [-v] [-c | -m metacluster] [-p package-path] package-name
The pkgdep utility displays the package dependencies for a specified package-name. This can be useful when determining which additional packages need to be installed to support a new package or which packages should be installed together in a custom Jumpstart profile.
Used without the -p package-path specifier, pkgdep examines the default package directory (/var/sadm/pkg) to find package-name. Used with the -p option, it examines a different location such as installation media.
If the -m metacluster specifier is used, pkgdep requires that a .clustertoc file exist in the package-path. If the package-path is not specified, the .clustertoc will be obtained from the default system location (/var/sadm/system/admin). Alternatively, the -c option can be used to display only dependencies not currently installed on the system, which examines the default package directory (/var/sadm/pkg).
The following options are supported. The -m metacluster and -p package-path specifier are described under “Operands”, below.
Display only dependencies which are not currently installed on the system. This option cannot be used in conjunction with the -m specifier.
Display full package descriptions instead of just package names.
The following operands are supported:
By default, pkgdep displays all the dependencies of the specified package-name. It may be useful to list any dependencies not included in a specific metacluster if adding a package to a custom Jumpstart profile. To specify the metacluster to check, the following can be used:
Display dependencies not included in metacluster. metacluster can be any of the following:
SUNWCXall - Entire Distribution plus OEM Support
SUNWCall - Entire Distribution
SUNWCprog - Developer System Support
SUNWCuser - End User System Support
SUNWCreq - Core System Support
SUNWCrnet - Reduced Networking Core System Support
SUNWCmreq - Minimal Core System Support
To specify an alternate directory in which to find the package, the following can be used:
The path in which to find the specified package-path.
Example 1 Determining Which Packages Should Be Installed Together
The following example displays dependent package descriptions for adding the Apache Server to the Core System Support metacluster found on a Solaris DVD.
example# pkgdep -v -m SUNWCreq \ -p /cdrom/cdrom0/Solaris_10/Product SUNWapch2r
Example 2 Making Sure All Dependent Packages Are Installed
The following example checks that all the dependent packages for Apache Server are installed. Any that are missing are listed.
example# pkgdep -c SUNWapch2r
Default file containing metacluster info.
See attributes(5) for descriptions of the following attributes: