|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- configure the Sun Expert3D Graphics Accelerator
/usr/lib/fbconfig/SUNWifb_config [-dev device-filename] [-res video-mode [now | try] [noconfirm | nocheck]] [-file machine | system] [-deflinear true | false] [-defoverlay true | false] [-linearorder first | last] [-overlayorder first | last] [-expvis enable | disable] [-slave enable | disable] [-accum enable | disable] [-g gamma-correction-value] [-gfile gamma-correction-file] [-propt] [-prconf] [-defaults] [-slave]  [-samples 1 | 2 | 4 | 8 | 16] [-multisample enable | disable | auto]
/usr/lib/fbconfig/SUNWifb_config [-propt] [prconf]
/usr/lib/fbconfig/SUNWifb_config [-help] [-res \?]
SUNWifb_config configures the Sun Expert3D Graphics Accelerator, Sun Expert3D-Lite, and Sun XVR-500 Graphics Accelerators, and some of the X11 window system defaults for the graphics accelerator.
The first form of SUNWifb_config shown in the synopsis above stores the specified options in the OWconfig file. These options will be used to initialize the Sun Expert3D device the next time the window system is run on that device. Updating options in the OWconfig file provides persistence of these options across window system sessions and system reboots.
The second and third forms of SUNWifb_config, which invoke only the -prconf, -propt, -help, and -res \? options, do not update the OWconfig file. Additionally, for the third form of the command, all other options are ignored.
Options may be specified for only one Sun Expert3D device at a time. Specifying options for multiple Sun Expert3D devices requires multiple invocations of SUNWifb_config.
Only options specific to the Sun Expert3D device can be specified through SUNWifb_config. The normal window system options for specifying default depth, default visual class and so forth are still specified as device modifiers on the openwin command line (see the Xsun(1) manual page in the OpenWindows Desktop Reference Manual).
The following options are supported:
Specifies the Sun Expert3D special file. The default is /dev/fbs/ifb0.
Specifies which OWconfig file to update. If machine is specified, the machine-specific OWconfig file in the /etc/openwin directory tree is updated. If system is specified, the global OWconfig file in the /usr/openwin directory tree is updated. If the specified file does not exist, it is created. This option has no effect unless other options are specified. The default is machine.
Specifies the video mode used to drive the monitor connected to the specified Sun Expert3D device.
The format of these built-in video modes is:
where width is the screen width in pixels, height is the screen height in pixels, and rate is the vertical frequency of the screen refresh. The s suffix of 960x680x112s and 960x680x108s means that these are stereo video modes. The i suffix of 640x480x60i and 768x575x50i designates interlaced video timing. If absent, non-interlaced timing will be used. As a convenience, -res also accepts formats with @ (at sign) in front of the refresh rate instead of x. For example: 1280x1024@76. Note that some video-modes supported by the Sun Expert3D device might not be supported by the monitor. The list of video-modes supported by the Sun Expert3D device and the monitor can be obtained by running SUNWifb_config with the -res \? option (shown in the command synopsis above). The following is a list of all possible video-modes supported on the Sun Expert3D device:
For convenience, some of the above video modes have symbolic names defined for them. Instead of the form width x height x rate, one of these names may be supplied as the argument to -res. The meaning of the symbolic name none is that when the window system is run the screen resolution will be the video mode that is currently programmed in the device.
Name Corresponding Video Mode _________ svga 1024x768x60 1152 1152x900x76 1280 1280x1024x76 stereo 960x680x112s ntsc 640x480x60i pal 768x575x50i none (see text above)
The res option also accepts additional, optional arguments immediately following the video mode specification. Any or all of the following might be present.
If present, not only will the video mode be updated in the OWconfig file, but the Sun Expert3D device will be immediately programmed to display this video mode. (This is useful for changing the video mode before starting the window system).
Note that it is inadvisable to use this suboption with SUNWifb_config while the configured device is being used (for example, while running the window system); unpredictable results might occur. To run SUNWifb_config with the now suboption, first bring the window system down. If the now suboption is used within a window system session, the video mode will be changed immediately, but the width and height of the affected screen will not change until the window system is exited and reentered again. In addition, the system may not recognize changes in stereo mode. Consequently, this usage is strongly discouraged.
Using the -res option, the user could potentially put the system into an unusable state, a state where there is no video output. This can happen if there is ambiguity in the monitor sense codes for the particular code read. To reduce the chance of this, the default behavior of SUNWifb_config is to print a warning message to this effect and to prompt the user to find out if it is okay to continue. The noconfirm option instructs SUNWifb_config to bypass this confirmation and to program the requested video mode anyway. This option is useful when SUNWifb_config is being run from a shell script.
If present, the normal error checking based on the monitor sense code (described above) will be suspended. The video mode specified by the user will be accepted regardless of whether it is appropriate for the currently attached monitor. (This option is useful if a different monitor is to be connected to the Sun Expert3D device). Use of this option implies noconfirm as well.
If present, the specified video mode will be programmed on a trial basis. The user will be asked to confirm the video mode by typing y within 10 seconds. Or the user may terminate the trial before 10 seconds are up by typing any character. Any character other than y or carriage return is considered a no and the previous video mode will be restored and SUNWifb_config will not change the video mode in the OWconfig file (other options specified will still take effect). If a carriage return is typed, the user is prompted for a yes or no answer on whether to keep the new video mode.
This sub-option should not be used with SUNWifb_config while the configured device is being used (for example, while running the window system) as unpredictable results may occur. To run SUNWifb_config with the try sub-option, the window system should be brought down first.
The Sun Expert3D device possesses two types of visuals: linear and nonlinear. Linear visuals are gamma corrected and nonlinear visuals are not. There are two visuals that have both linear and nonlinear versions: 24-bit TrueColor and 8-bit StaticGray. If true, the default visual is set to the linear visual that satisfies other specified default visual selection options (specifically, the Xsun(1) -defdepth and -defclass options described in the OpenWindows Desktop Reference Manual). If false, or if there is no linear visual that satisfies the other default visual selection options, the non-linear visual specified by these other options will be chosen to be the default. This option cannot be used when the -defoverlay option is present, because the Sun Expert3D does not possess a linear overlay visual.
The Sun Expert3D device provides an 8-bit PseudoColor visual whose pixels are disjoint from the rest of the Sun Expert3D visuals. This is called the overlay visual. Windows created in this visual will not damage windows created in other visuals. The converse, however, is not true. Windows created in other visuals will damage overlay windows. If the value of this option is true, the overlay visual will be made the default visual. If false, the nonoverlay visual that satisfies the other default visual selection options, such as -defdepth and -defclass, will be chosen as the default visual. See the Xsun(1) manual page in the OpenWindows Desktop Reference Manual. Whenever -defoverlay true is used, the default depth and class chosen on the openwin command line must be 8-bit PseudoColor. If not, a warning message will be printed and the -defoverlay option will be treated as false. This option cannot be used when the -deflinear option is present, because the Sun Expert3D device does not possess a linear overlay visual.
If first, linear visuals will come before their non-linear counterparts on the X11 screen visual list for the Sun Expert3D screen. If last, the nonlinear visuals will come before the linear ones.
If -first, the depth 8 PseudoColor Overlay visual will come before the non-overlay visual on the X11 screen visual list for the Sun Expert3D screen. If last, the non-overlay visual will come before the overlay one.
If enabled, OpenGL Visual Expansion will be activated. Multiple instances of selected visual groups (8-bit PseudoColor, 24-bit TrueColor, and so forth) can be found in the screen visual list.
If enabled, the video for this frame buffer will be synced with the video of the display which is connected to it. For applications which support it buffers will also be swapped synchronously.
If enabled, frame buffer memory is allocated for accelerated accumulation buffer for windows. If disabled, software accumulation buffering will be done for windows. Accelerated accumulation buffers for pBuffers are always available as memory allows.
This option allows changing the gamma correction value. All linear visuals provide gamma correction. By default the gamma correction value is 2.22. Any value less than zero is illegal. The gamma correction value is applied to the linear visual, which then has an effective gamma value of 1.0, which is the value returned by XSolarisGetVisualGamma(). See XSolarisGetVisualGamma(3) for a description of that function.This option can be used while the window system is running. Changing the gamma correction value will affect all the windows being displayed using the linear visuals.
This option loads gamma correction table from the specified file. This file should be formatted to provide the gamma correction values for R, G and B channels on each line. Each of these values should be in hexadecimal format and separated from each other by at least one space. Also, this file should provide 1024 such triplets. An example of this file is as follows.
0x00 0x00 0x000 0x01 0x01 0x001 0x02 0x02 0x002 ... ... 0x3ff 0x3ff 0x3ff
Using this option, the gamma correction table can be loaded while the window system is running. The new gamma correction will affect all the windows being displayed using the linear visuals. Note that, when gamma correction is being done using a user-specified table, the gamma correction value is undefined. By default, the window system assumes a gamma correction value of 2.22 and loads the gamma table it creates corresponding to this value.
Resets all option values to their default values.
Prints the current values of all Sun Expert3D options in the OWconfig file specified by the -file option for the device specified by the -dev option. Prints the values of options as they will be in the OWconfig file after the call to SUNWifb_config completes. This is a typical display:
--- OpenWindows Configuration for /dev/fbs/ifb0 --- OWconfig: machine Video Mode: 1280x1024x76 Accum: Disabled (do not allocate an accumulation buffer) Default Visual: Non-Linear Normal Visual Visual Ordering: Linear Visuals are last Overlay Visuals are last OpenGL Visual Expansion: enabled Gamma Correction Value: 2.22 Gamma Correction Table: Available
Prints the Sun Expert3D hardware configuration. This is a typical display:
--- Hardware Configuration for /dev/fbs/ifb0 --- PROM Information: @(#)ifb.fth 1.25 99/10/12 SMI EDID Data: Available - EDID version 1 revision 1 Monitor possible resolutions: 1024x768x60, 1024x768x70, 1024x768x75, 1152x900x66, 1152x900x76, 1280x1024x67, 1280x1024x76, 960x680x112s, 640x480x60 Current resolution setting: 1280x1024x76
Prints a list of the SUNWifb_config command-line options, along with a brief explanation of each.
Requested number of samples to compute per display pixel. The requested number of samples per pixel will be used if -multisample is not disabled and resouces exist for the request.
Query the number of samples used with -propt (see above) or the xglinfo utility. The xglinfo utility can return the number of multisamples after you specify the option -multisample enable.
The default is 16.
If set to disable, no multisample is possible. If set to enable, multisample is possible but is selected on a per-window basis using a library interface. If set to auto, all Sun OpenGL windows are rendered using multisampling.
Query the number of samples used with -propt (see above) or the xglinfo utility. The xglinfo utility can return the number of multisamples if -multisample is set to enable.
The default is disable.
The xglinfo utility is shipped with the Sun OpenGL package, SUNWglrt. The man page for xglinfo is part of another Sun OpenGL package, SUNWgldoc.
For a given invocation of SUNWifb_config command line if an option does not appear on the command line, the corresponding OWconfig option is not updated; it retains its previous value. When the window system is run, if an Sun Expert3D option has never been specified via SUNWifb_config, a default value is used. The option defaults are as follows:
Option Default ________ -dev /dev/fbs/ifb0 -file machine -res none -deflinear false -defoverlay false -linearorder last -overlayorder last -expvis enable -slave disable -accum enable -g 2.22 -samples 16 -multisample disable
The default for the -res option of none means that, when the window system is run, the screen resolution will be the video mode that is currently programmed in the device. This design choice provides compatibility for users who are used to specifying the device resolution through the PROM. On some devices (for example, GX), this is the only way of specifying the video mode. This means that the PROM ultimately determines the default Sun Expert3D video mode.
Example 1 Changing Monitor Resolution
The following example switches the monitor type to the resolution of 1280 x 1024 at 76 Hz:
example% /usr/lib/fbconfig/SUNWifb_config -res 1280x1024x76
device special file
See attributes(5) for descriptions of the following attributes: