|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- displays information about processors
psrinfo [-p] [-v] [processor_id]...
psrinfo [-p] -s processor_id
psrinfo displays information about processors. Each physical processor may support multiple virtual processors. Each virtual processor is an entity with its own interrupt ID, capable of executing independent threads.
Without the processor_id operand, psrinfo displays one line for each configured processor, displaying whether it is on-line, non-interruptible (designated by no-intr), spare, off-line, faulted or powered off, and when that status last changed. Use the processor_id operand to display information about a specific processor. See OPERANDS.
The following options are supported:
Silent mode. Displays 1 if the specified processor is fully on-line. Displays 0 if the specified processor is non-interruptible, spare, off-line, faulted or powered off.
Use silent mode when using psrinfo in shell scripts.
Display the number of physical processors in a system.
When combined with the -v option, reports additional information about each physical processor.
Verbose mode. Displays additional information about the specified processors, including: processor type, floating point unit type and clock speed. If any of this information cannot be determined, psrinfo displays unknown.
When combined with the -p option, reports additional information about each physical processor.
The following operands are supported:
The processor ID of the processor about which information is to be displayed.
Specify processor_id as an individual processor number (for example, 3), multiple processor numbers separated by spaces (for example, 1 2 3), or a range of processor numbers (for example, 1-4). It is also possible to combine ranges and (individual or multiple) processor_ids (for example, 1-3 5 7-8 9).
Example 1 Displaying Information About All Configured Processors in Verbose Mode
The following example displays information about all configured processors in verbose mode.
Example 2 Determining If a Processor is On-line
The following example uses psrinfo in a shell script to determine if a processor is on-line.
if [ "`psrinfo -s 3 2> /dev/null`" -eq 1 ] then echo "processor 3 is up" fi
Example 3 Displaying Information About the Physical Processors in the System
With no additional arguments, the -p option displays a single integer: the number of physical processors in the system:
> psrinfo -p 8
psrinfo also accepts command line arguments (processor IDs):
> psrinfo -p 0 512 # IDs 0 and 512 exist on the 1 # same physical processor > psrinfo -p 0 1 # IDs 0 and 1 exist on different 2 # physical processors
In this example, virtual processors 0 and 512 exist on the same physical processor. Virtual processors 0 and 1 do not. This is specific to this example and is and not a general rule.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
The specified processor does not exist.