|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- receive and log SNMP trap messages
/usr/sfw/sbin/snmptrapd [options] [listening addresses]
The snmptrapd utility is an SNMP application that receives and logs SNMP TRAP and INFORM messages.
The default is to listen on UDP port 162 on all IPv4 interfaces. Because 162 is a privileged port, snmptrapd must be be run as root.
This command supports the following options:
Ignore authenticationFailure traps.
Read file as a configuration file.
Do not read any configuration files except the one optionally specified by the -c option.
Dump (in hexadecimal) the sent and received SNMP packets.
Turn on debugging output for the specified token(s). Use ALL for extremely verbose output.
Print event numbers (rising/falling alarm, and so forth).
Do not call fork() from the calling shell.
When logging to standard output, use the format in the string format. See Format Specifications below for more details.
Display a brief usage message and then exit.
Display a list of configuration file directives understood by the trap daemon and then exit.
Specifies the syslog(3C) facility to use when logging to syslog. d means LOG_DAEMON; 0 through 7 means LOG_LOCAL0 through LOG_LOCAL7. LOG_LOCAL0 is the default.
Specifies a colon-separated list of MIB modules to load for this application. This overrides the environment variable MIBS.
Specifies a colon-separated list of directories to search for MIBs. This overrides the environment variable MIBDIRS.
Do not attempt to translate source addresses of incoming packets into host names.
Log formatted incoming traps to file. Upon receipt of a SIGHUP, the daemon will close and reopen the log file. This feature is useful when rotating the log file with other utilities such as logrotate.
Print formatted incoming traps to stderr.
Log formatted incoming traps to syslog(3C). These syslog messages are sent with a level of LOG_WARNING and facility as determined by the -l flag (LOG_LOCAL0 by default). This is the default unless you use the -o or -P flag.
Save the process ID of the trap daemon in file.
Print version information for the trap daemon and then exit.
In addition to the preceding options, snmptrapd takes the same output formatting options as the other Net-SNMP commands. See the section OUTPUT OPTIONS in snmpcmd(1M).
For extensibility and configuration information, see snmptrapd.conf(4).
snmptrapd interprets format strings similarly to printf(3C). It interprets the following formatting sequences:
A literal percent sign(%).
Decimal number of seconds since the operating system's epoch, as returned by time(2).
Current year on the local system.
Current (numeric) month on the local system.
Current day of month on the local system.
Current hour on the local system.
Current minute on the local system.
Current second on the local system.
The value of the sysUpTime.0 varbind in seconds.
The year field from the sysUpTime.0 varbind.
The numeric month field from the sysUpTime.0 varbind.
The day of month field from the sysUpTime.0 varbind.
The hour field from the sysUpTime.0 varbind.
The minute field from the sysUpTime.0 varbind.
The seconds field from the sysUpTime.0 varbind.
The contents of the agent-addr field of the PDU (v1 TRAPs only).
The hostname corresponding to the contents of the agent-addr field of the PDU, if available. Otherwise the contents of the agent-addr field of the PDU (v1 TRAPs only).
PDU source address (note that this is not necessarily an IPv4 address).
PDU source hostname if available, otherwise PDU source address (which is not necessarily an IPv4 address).
Trap type (numeric, in decimal).
Trap sub-type (numeric, in decimal).
Security information from the PDU (community name for v1/v2c, user and context for v3).
List of trap's variable-bindings.
In addition to these values, you can also specify an optional field width and precision, just as in printf(3C), and a flag value. The following flags are valid:
use leading zeros
use alternate form
The "use alternate form" flag changes the behavior of some format flags. Normally, the fields that display time information base it on the local timezone, but this flag tells them to use GMT instead. Also, the variable-binding list is normally a tab-separated list, but this flag changes it to a comma-separated one. The alternate form for the uptime is similar to "3 days, 0:14:34.65".
By default, snmptrapd listens for incoming SNMP TRAP and INFORM packets on UDP port 162 on all IPv4 interfaces. However, it is possible to modify this behavior by specifying one or more listening addresses as arguments to snmptrapd. See snmpd(1M) for more information about the format of listening addresses.NOTIFICATION-LOG-MIB Support
As of Net-SNMP 5.0, the snmptrapd application supports the NOTIFICATION-LOG-MIB. It does this by opening an AgentX subagent connection to the master snmpd agent and registering the notification log tables. As long as the snmpd application is started first, it will attach itself to it. Thus you should be able to view the last recorded notifications by means of the nlmLogTable and nlmLogVariableTable. See snmptrapd.conf(4) and the dontRetainLogs token for turning off this support. See the NOTIFICATION-LOG-MIB for more details about the MIB itself.
Example 1 Using snmptrapd
To get a message such as 14:03 TRAP3.1 from humpty.example.edu you can use a command similar to:
# snmptrapd -P -F "%02.2h:%02.2j TRAP%w.%q from %A\n"
If you want the same effect, but in GMT rather than local time, use:
# snmptrapd -P -F "%#02.2h:%#02.2j TRAP%w.%q from %A\n"
Example 2 Viewing Traps on the Host on Which You Invoke snmptrapd
To view traps on the host from which you invoke snmptrapd, enter:
# snmptrapd -P
The preceding command sends output to stdout rather than to a log file.
A usage syntax error. A usage message is displayed. Also used for timeout errors.
See attributes(5) for descriptions of the following attributes: