|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- communicate with a network entity using SNMP GETNEXT requests
snmpwalk [application options] [common options] [oid]
The snmpwalk utility is an SNMP application that uses SNMP GETNEXT requests to query a network entity for a tree of information.
You can specify an object identifier (OID) on the command line. This OID specifies which portion of the object identifier space will be searched using GETNEXT requests. All variables in the subtree below the specified OID are queried and their values returned. Each variable name must be entered in the format specified in snmp_variables(4).
If no OID argument is present, snmpwalk searches MIB-2. If the network entity has an error processing the request packet, an error packet is returned and a message displayed, indicating t the way in which the request was malformed.
If the tree search causes attempts to search beyond the end of the MIB, the message “End of MIB” is displayed.
The following options are supported:
Do not check whether the returned OIDs are increasing. Some agents (for example, agents for Laser-Jet printers) return OIDs out of order, but can complete the walk anyway. Other agents return OIDs that are out of order and can cause snmpwalk to loop indefinitely. By default, snmpwalk tries to detect this behavior and warns you when it encounters an agent acting illegally. Use -Cc to turn off this feature.
Include the given OID in the search range. Normally, snmpwalk uses GETNEXT requests starting with the OID you specify and returns all results in the MIB tree beyond that OID. This option allows you to include the OID specified on the command line in the displayed results (assuming the OID is a valid OID in the tree).
Upon completion of the walk, display the number of variables found.
In addition to these options, snmpwalk takes the common options described in the snmpcmd(1M) manual page.
Example 1 Retrieving All of the Variables Under system
The following command retrieves all of the variables under system:
# snmpwalk -Os -c public -v 1 zeus system
Output from this command will be similar to:
sysDescr.0 = STRING: "SunOS zeus.net.cmu.edu 4.1.3_U1 1 sun4m" sysObjectID.0 = OID: enterprises.hp.nm.hpsystem.10.1.1 sysUpTime.0 = Timeticks: (155274552) 17 days, 23:19:05 sysContact.0 = STRING: "" sysName.0 = STRING: "zeus.net.cmu.edu" sysLocation.0 = STRING: "" sysServices.0 = INTEGER: 72
See attributes(5) for descriptions of the following attributes:
A usage syntax error. A usage message is displayed. Also used for timeout errors.
An error occurred while executing the command. An error message is displayed.