man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2014
 
 

copyreq(9S)

Name

copyreq - STREAMS data structure for the M_COPYIN and the M_COPYOUT message types

Synopsis

#include <sys/stream.h> 

Interface Level

Architecture independent level 1 (DDI/DKI)

Description

The data structure for the M_COPYIN and the M_COPYOUT message types.

Structure Members


int      cq_cmd;           /* ioctl command (from ioc_cmd) */
cred_t   *cq_cr;           /* full credentials */
uint_t   cq_id;            /* ioctl id (from ioc_id) */
uint_t   cq_flag;	       /* must be zero */
mblk_t   *cq_private;      /* private state information */
caddr_t  cq_addr;          /* address to copy data to/from */
size_t   cq_size;          /* number of bytes to copy */	

See also

STREAMS Programming Guide