man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2014
 
 

lso_basic_tcp_ipv4(9S)

Name

mac_capab_lso, lso_basic_tcp_ipv4 - LSO capability data structure

Synopsis

#include <sys/mac_provider.h>

Interface Level

Solaris architecture specific (Solaris DDI)

Description

The mac_capab_lso and lso_basic_tcp_ipv4 structures are used by a device driver to describe its LSO capability. The structure is used as the argument to the mc_getcapab(9E) driver entry point when querying the MAC_CAPAB_LSO capability.

Structure Members

The mac_capab_lso data structure has the following members:

t_uscalar_t             lso_flags;
lso_basic_tcp_ipv4_t    lso_basic_tcp_ipv4;

The fields must be set as follows:

lso_flags

Flag indicating the LSO capability supported by the device driver instance. The following flags are currently supported:

LSO_TX_BASIC_TCP_IPV4

LSO for TCP on IPv4

lso_basic_tcp_ipv4

Parameters for TCP LSO over IPv4

The lso_basic_tcp_ipv4 data structure is used by the device driver to advertise specific parameters when the LSO_TX_BASIC_TCP_IPV4 lso_flag is set. This data structure has the following elements:

t_uscalar_t             lso_max;

The lso_max field contains the maximum payload size supported by the driver instance.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/header
Interface Stability
Committed

See also

attributes(5), mc_getcapab(9E) , mac_lso_get(9F), mac_register (9F)