man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2014
 
 

linkblk(9S)

Name

linkblk - STREAMS data structure sent to multiplexor drivers to indicate a link

Synopsis

#include <sys/stream.h> 

Interface Level

Architecture independent level 1 (DDI/DKI)

Description

The linkblk structure is used to connect a lower Stream to an upper STREAMS multiplexor driver. This structure is used in conjunction with the I_LINK, I_UNLINK, P_LINK, and P_UNLINK ioctl commands. See streamio(7I). The M_DATA portion of the M_IOCTL message contains the linkblk structure. Note that the linkblk structure is allocated and initialized by the Stream head as a result of one of the above ioctl commands.

Structure Members


queue_t   *l_qtop;   /* lowest level write queue of upper stream */
                     /* (set to NULL for persistent links) */
queue_t   *l_qbot;   /* highest level write queue of lower stream */
int       l_index;   /* index for lower stream. */

See also

ioctl(2), streamio(7I)

STREAMS Programming Guide