man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2014
 
 

kstat_named(9S)

Name

kstat_named - structure for named kstats

Synopsis

#include <sys/types.h>
#include <sys/kstat.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

Interface Level

Solaris DDI specific (Solaris DDI)

Description

Named kstats are an array of name-value pairs. These pairs are kept in the kstat_named structure. When a kstat is created by kstat_create(9F), the driver specifies how many of these structures will be allocated. The structures are returned as an array pointed to by the ks_data field.

Structure Members


union {
          char                   c[16];
          long                   l;
          ulong_t                ul; 
          longlong_t             ll;
          u_longlong_t           ull;
} value;  /* value of counter */ 

The only member exposed to drivers is the value member. This field is a union of several data types. The driver must specify which type it will use in the call to kstat_named_init().

See also

kstat_create(9F), kstat_named_init( 9F)

Writing Device Drivers for Oracle Solaris 11.2