man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2014
 
 

streamtab(9S)

Name

streamtab - STREAMS entity declaration structure

Synopsis

#include <sys/stream.h> 

Interface Level

Architecture independent level 1 (DDI/DKI).

Description

Each STREAMS driver or module must have a streamtab structure.

streamtab is made up of qinit structures for both the read and write queue portions of each module or driver. Multiplexing drivers require both upper and lower qinit structures. The qinit structure contains the entry points through which the module or driver routines are called.

Normally, the read QUEUE contains the open and close routines. Both the read and write queue can contain put and service procedures.

Structure Members

struct qinit    *st_rdinit;    /* read QUEUE */
struct qinit    *st_wrinit;    /* write QUEUE */
struct qinit    *st_muxrinit;  /* lower read QUEUE*/
struct qinit    *st_muxwinit;  /* lower write QUEUE*/

See also

qinit(9S)

STREAMS Programming Guide