|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- Intel Gigabit Ethernet Virtual Function Driver
The igbvf Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on the Virtual Function of Intel 82576 Gigabit Ethernet controller.
The igbvf driver functions include Virtual Function initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.
The igbvf driver works on the Virtual Function of Intel 82576 Gigabit Ethernet controller only when the SRIOV capability of the controller is enabled.
The igbvf driver does not support link configuration. The link configuration is controlled by the Physical Function of the 82576 controller, which is supported by the igb(7D) driver.
Special character device
64-bit device driver (x86)
64-bit device driver (SPARC)
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide