|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library|
- Mellanox ConnectX-2 10GbE NIC Driver
The mcxe 10 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based, STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on Mellanox ConnectX-2 10GigE controllers.
The mcxe driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support.
The cloning character-special device, /dev/mcxe, is used to access all Mellanox ConnectX–2 10-Gigabit devices installed within the system.
You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach.
The values returned by the driver in the DL_INFO_ACK primitive in response to your DL_INFO_REQ are:
Maximum SDU is 9000.
Minimum SDU is 0.
DLSAP address length is 8.
MAC type is DL_ETHER.
SAP (Service Access Point) length value is -2, meaning the physical address component is followed immediately by a 2-byte SAP component within the DLSAP address.
Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular SAP with the stream.
The mcxe driver performs auto-negotiation to select the link speed and mode. Link speed and mode can only be 10000 Mbps full-duplex. See the IEEE 802.3 Standard for more information.
Special character device
64-bit device driver (x86)
See attributes(5) for a description of the following attributes:
IEEE 802.3 Standard
Writing Device Drivers
Network Interface Guide
STREAMS Programming Guide