|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- per-user auditing data file
audit_user is a database that stores per-user auditing preselection data. You can use the audit_user file with other authorization sources, including the NIS map audit_user.byname and the NIS+ table audit_user. Programs use the getauusernam(3BSM) routines to access this information.
The fields for each user entry are separated by colons (:). Each user is separated from the next by a newline. audit_user does not have general read permission. Each entry in the audit_user file has the form:
The fields are defined as follows:
User's login name.
Flags specifying event classes to always audit.
Flags specifying event classes to never audit.
For a complete description of the audit flags and how to combine them, see audit_control(4).
Example 1 Using the audit_user File
other:lo,am:io,cl fred:lo,ex,+fc,-fr,-fa:io,cl ethyl:lo,ex,nt:io,cl
See attributes(5) for descriptions of the following attributes:
This functionality is available only if the Basic Security Module (BSM) has been enabled. See bsmconv(1M) for more information.
Configuration changes do not affect audit sessions that are currently running, as the changes do not modify a process's preselection mask. To change the preselection mask on a running process, use the –setpmask option of the auditconfig command (see auditconfig(1M)). If the user logs out and logs back in, the new configuration changes are reflected in the next audit session.
This file and name service database is Obsolete and may be removed and replaced by equivalent functionality in a future release of Solaris.