|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- name service cache daemon configuration
The nscd.conf file contains the configuration information for nscd(1M). Each line specifies either an attribute and a value, or an attribute, cachename, and a value. Fields are separated either by SPACE or TAB characters. A `#' (number sign) indicates the beginning of a comment; characters up to the end of the line are not interpreted by nscd.
cachename is represented by hosts, ipnodes, passwd, group, exec_attr, prof_attr, user_attr, ethers, rpc, protocols, networks, bootparams, audit_user, auth_attr, services, netmasks, printers, or project.
The attribute field supports the following:
Enables or disables checking the file belonging to the specified cachename for changes. If enabled (which is the default), changes in the corresponding file cause the cache to be invalidated within 10 seconds. Can be disabled if files are never modified for a slight performance boost, particularly over NFS. value may be either yes or no.
Sets the debug level desired. value may range from 0 (the default) to 10. Use of this option causes nscd(1M) to run in the foreground and not become a daemon. Note that the output of the debugging command is not likely to remain the same from release-to-release; scripts should not rely on its format.
Enables or disables the specified cache. value may be either yes or no.
Enables or disables the ability of nscd to create a per-user nscd. A per-user nscd performs per-user lookups and manages the per-user cache. The per-user lookups might not be possible if the corresponding name service switch backends do not support it or are not configured to do so. The value of this attribute can be either yes or no.
This attribute allows the administrator to set the number of entries nscd(1M) is to keep current in the specified cache. value is an integer number which should approximate the number of entries frequently used during the day.
Specifies name of the file to which debug info should be written. Use /dev/tty for standard output.
Sets the maximum number of per-user nscds that can be created and managed by the main nscd daemon. The value is an integer.
Sets the time-to-live for negative entries (unsuccessful queries) in the specified cache. value is in integer seconds. Can result in significant performance improvements if there are several files owned by uids (user IDs) not in system databases; should be kept small to reduce cache coherency problems.
Sets the time-to-live value for a per-user nscd based on the last time the per-user nscd was active. The value is an integer that specifies a number of seconds.
Sets the time-to-live for positive entries (successful queries) in the specified cache. value is in integer seconds. Larger values increase cache hit rates and reduce mean response times, but increase problems with cache coherence. Note that sites that push (update) NIS maps nightly can set the value to be the equivalent of 12 hours or more with very good performance implications.
Sets the suggested number of hash buckets in the specified cache. This parameter should be changed only if the number of entries in the cache exceeds the suggested size by more than a factor of four or five. Since this is the internal hash table size, value should remain a prime number for optimum efficiency.
This attribute is obsolete and will be silently ignored. nscd now automatically adjusts the hash table size.
See attributes(5) for descriptions of the following attributes:
nscd(1M), audit_user(4), auth_attr(4), bootparams(4), ethers(4), exec_attr(4), group(4), hosts(4), netmasks(4), networks(4), passwd(4), printers(4), prof_attr(4), project(4), protocols(4), rpc(4), services(4), user_attr(4), attributes(5)