|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- FACE object architecture information
The FACE object architecture stores information about object-types in an ASCII file named .ott (object type table) that is contained in each directory. This file describes all of the objects in that directory. Each line of the .ott file contains information about one object in pipe-separated fields. The fields are (in order):
the name of the actual system file.
the name that should be displayed to the user, or a dot if it is the same as the name of the file.
the description of the object, or a dot if the description is the default (the same as object-type).
the FACE internal object type name.
object specific flags.
the time that FACE last modified the object. The time is given as number of seconds since 1/1/1970, and is in hexadecimal notation.
an optional field, contains a set of semi-colon separated name=value fields that can be used by FACE to store any other information necessary to describe this object.
.ott is created in any directory opened by FACE.