|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- Network Information Service Version 2, formerly knows as YP
The NIS network information service uses a distributed, replicated database of dbm files , in ASCII form, that are contained in the /var/yp directory hierarchy on each NIS server.
A dbm database served by the NIS server is called a NIS map. A NIS domain is a subdirectory of /var/yp that contains a set of NIS maps on each NIS server.
Standard nicknames are defined in the file /var/yp/nicknames. These names can be used in place of the full map name in the ypmatch and ypcat commands. Use the command ypwhich -x to display the current set of nicknames. Use the command ypwhich -m to display all the available maps. Each line of the nickname file contains two fields separated by white space. The first field is the nickname, and the second field is the name of the map that it expands to. The nickname cannot contain a ".".
If the /var/yp/NISLDAPmapping configuration file is present, the NIS server operates in NIS to LDAP (N2L) mode. In this mode, NIS maps are stored in a new set of DBM files, prepended by the LDAP_ prefix, at /var/yp/domainename. These files are used as a cache backed by information from an LDAP server. Additional DBM files are created in the same directory to hold the cache's TTL values.
N2L mode enables NIS clients to be supported in an LDAP environment.
In N2L mode, the old style DBM files, NIS source files, and the ypmake(1M) utility have to role. They are retained to enable easy conversion back to the traditional mode, if required.
When NIS is operating in N2L mode, it uses a new set of NIS maps with an LDAP_ prefix, based on the contents of the LDAP DIT. The NIS source files are unused and become out of date. If you wish to convert back to the traditional NIS mode, the N2L configuration file should be deleted. The system will then return to using the standard map files. Optionally, the N2L mode map files, /var/yp/*/LDAP_* can also be deleted.
If you want to run the system in traditional mode with information based on the DIT, then the NIS source files must be regenerated based on the N2L maps. To regenerate the NIS source files based on the N2L maps, run ypmap2src(1M).
NIS+ also provides a NIS service when it runs in YP-compatibility mode. See NIS+(1) and rpc.nisd(1M). NIS+, in any mode, cannot be run on the same system as ypserv, whether ypserv is in traditional or N2L mode.
Directory containing NIS configuration files.
Stores the information required to bind the NIS client to the NIS server.
Contains the servers to which the NIS client is allowed to bind.
Builds the NIS ndbm databases.
Defines the hosts and networks that are granted access to information in the served domain. This file is read at startup time by ypserv and ypxfrd.
Directory containing ndbm databases.
NIS to LDAP configuration file
NIS to LDAP mode map files
The NIS+ server, rpc.nisd, when run in "YP-compatibility mode", can support NIS clients only for the standard NIS maps listed below, provided that it has been set up to serve the corresponding NIS+ tables using nissetup(1M) and nisaddent(1M). The NIS+ server should serve the directory with the same name (case sensitive) as the domainname of the NIS client. NIS+ servers use secure RPC to verify client credentials but the NIS clients do not authenticate their requests using secure RPC. Therefore, NIS clients can look up the information stored by the NIS+ server only if the information has "read" access for an unauthenticated client, that is, one with nobody NIS+ credentials.