|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- package installation order description file
The package installation order file, .order, is an ASCII file specifying the order in which packages must be installed based on their prerequisite dependencies. Any package with prerequisite dependencies must be installed after any packages it lists as a prerequisite dependency in its depend file.
A .order file is required for the OS product. The .order file must reside in the top-level directory containing the product.
The ordering is specified as a list of package identifiers, from the first package to be installed to the last, one package identifier per line.
The depend file supports incompatible and reverse dependencies. These dependency types are not recognized in the order file.